Custom UITableVIew

Para dar las gracias debes entrar o registrarte en el foro

iMiembro
iMiembro
Mensajes: 10 Agradecido: 0
13 Sep 2012, 22:43# 1

Hola, soy nuevo en la programación en ios.
Estoy creando una tabla, con celdas personalizadas. Por ahora sólo le he puesto color a la celda, 2 label (usuario, email) y una imagen. El problema está que cuándo simulo el código, me aparece una tabla con celdas (sin el color que le había asignado) y a simple vista sin datos, pero con las imágenes precargadas. Al pulsar en las celdas, me aparecen los dos labels, pero solo al pulsar, es como que seleccionando me aparecen los labels. No entiendo porque la imagen se precarga pero los labels no, y tampoco el color. Os dejo el código del cellForRowAtIndexPath a ver si véis algo. Los datos se recogen de una Base de datos remota alojada en un servidor externo. Mi celda es SimpleCell.

- (SimpleCell *)tableView:(UITableView *)tableView cellForRowAtIndexPath:(NSIndexPath *)indexPath{

static NSString *CellIdentifier = @"SimpleCell";

SimpleCell *cell = (SimpleCell *)[tableView dequeueReusableCellWithIdentifier:CellIdentifier];
if (cell == nil)
{
NSArray *nib = [[NSBundle mainBundle] loadNibNamed:CellIdentifier owner:self options:nil];
cell = [nib objectAtIndex:0];
}

NSDictionary *dict = [rows objectAtIndex:indexPath.row];

cell.usuario.text = [dict objectForKey:@"userid"];
cell.email.text = [dict objectForKey:@"email"];
cell.imagen.image = [UIImage imageNamed:[dict objectForKey:@"firstname"]];

return cell;

}

Gracias  
Etiquetado en:
Enviar vídeos y música para iPad
Publicidad
Publicidad